-
Type: Improvement
-
Resolution: Fixed
-
Priority: Major - P3
-
Affects Version/s: None
-
Component/s: cmake
-
None
While porting config checks from Autotools to CMake we ended up with a mix of variable names, some ending with LIBS and some ending with LIBRARIES. This is a bug factory. For example, if you include SSL_LIBRARIES in a list of dependencies in a pkg-config file, that will be replaced with the empty string which (sometimes!) causes a linker error because it should have been SSL_LIBS.
LIBRARIES is the proper convention for CMake variables. For example, the built-in script FindOpenSSL sets OPENSSL_LIBRARIES. Once we've deleted the Autotools scripts let's rename all the LIBS variables to LIBRARIES. This should have no publicly visible effect, these variables are all internal.