-
Type: Bug
-
Resolution: Fixed
-
Priority: Major - P3
-
Affects Version/s: None
-
Component/s: Portability
-
Storage Execution
-
Fully Compatible
-
ALL
-
Execution Team 2024-07-08, Execution Team 2024-07-22, Execution Team 2024-08-05, Execution Team 2024-08-19
-
200
1. BackupCursor Unit Tests use BackupBlock interface improperly (functional)
Some unit tests in the enterprise repo improperly pass in a filename stem instead of a filepath to the BackupBlock() constructor. Much of this code is brittle. Some examples:
- TestTypicalCursorLifetime (backup_cursor_service_test.cpp)
- TestFilenameCheck (document_source_backup_cursor_test.cpp)
2. _forTest & _ForTest naming is inconsistent (style)
standardize on _forTest which is more prevalent
src/fcbis/file_copy_based_initial_syncer.h
src/fcbis/file_copy_based_initial_syncer_test.cpp
- getBackupCursorFiles_ForTest
- getExtendedBackupCursorFiles_ForTest
- setOldStorageFilesToBeDeleted_ForTest
- corollary: getOldStorageFilesToBeDeleted_forTest
- is related to
-
SERVER-89625 Handle directoryPerDb and wiredTigerDirectoryForIndexes correctly when reporting namespaces and UUIDs during a backup
- Closed