Uploaded image for project: 'Core Server'
  1. Core Server
  2. SERVER-69998

Rename TenantMigrationAccessBlocker public methods

    • Type: Icon: Improvement Improvement
    • Resolution: Won't Fix
    • Priority: Icon: Major - P3 Major - P3
    • None
    • Affects Version/s: None
    • Component/s: None
    • None

      It would be nice to remove any mention of "migration" from TenantMigrationAccessBlocker method names.

      For example:

      • TenantMigrationAccessBlockerRegistry => TenantAccessBlockerRegistry
      • getTenantMigrationAccessBlockerForDbName => getAccessBlockerForDbName
      • getTenantMigrationAccessBlockerForTenantId => getAccessBlockerForTenantId

      There's also a question about consistency of method names on this class. get is a global helper which returns the decorated value on a serviceContext, so we can't use that name to also return access blockers. On the other hand, we have add/remove/removeAll which don't reference access blockers. We should choose one of these names and make them consistent:

      • addAccessBlockerForTenant
      • addAccessBlockerForTenants
      • addGlobalAccessBlocker
      • getAccessBlockerForTenant
      • removeAccessBlocker
        etc

      Finally, we should investigate replacing DonorRecipientAccessBlockerPair with something simpler like:

      using DonorRecipientAccessBlockerPair = std::pair<std::shared_ptr, std::shared_ptr>;

            Assignee:
            christopher.caplinger@mongodb.com Christopher Caplinger
            Reporter:
            christopher.caplinger@mongodb.com Christopher Caplinger
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Created:
              Updated:
              Resolved: