-
Type: Technical Debt
-
Resolution: Fixed
-
Priority: Major - P3
-
Affects Version/s: None
-
Component/s: Compaction, Test Format
-
2
-
StorEng - Defined Pipeline
This ticket needs to make sure we are using "background" instead of "bg" or any other abbreviation in the code base.
Furthermore, in the "conn_compact.c" file, we should make sure to add the "background" prefix to all functions. For instance:
__compact_server_run_chk # Becomes __background_compact_server_run_chk
In test/format, we have background_compact and background_compact.free_space_target but we have ops.compaction and compact.free_space_target which could seem weird. Why is one called "compaction" and the other "compact" while we are referring to the same operation? We should make sure to avoid confusion.
Finally, the macros present in the conn_compact.c file should be checked again so they contain the prefix "BACKGROUND_COMPACT".